DCAudioDIY.com
http://dcaudiodiy.com/phpBB3/

Dynaco SCA80Q Selector Switch
http://dcaudiodiy.com/phpBB3/viewtopic.php?f=4&t=1738
Page 1 of 1

Author:  Stuart Polansky [ November 5th, 2020, 2:54 pm ]
Post subject:  Dynaco SCA80Q Selector Switch

I am in desperate need of at least one wafer. Nearing the end of a project to refurbish one using an LM4780 chip amp in place of a failed power amp and recapped/re-resistored line/phono stage when I discovered the broken wafer.

It MAY becthe same as a PAT4. Does anyone have one or have a source for one. Ebay and Marketplace searches come up with nothing.

Thanks in advance,

Stuart

Author:  SoundMods [ November 5th, 2020, 3:40 pm ]
Post subject:  Re: Dynaco SCA80Q Selector Switch

Stuart Polansky wrote:
I am in desperate need of at least one wafer. Nearing the end of a project to refurbish one using an LM4780 chip amp in place of a failed power amp and recapped/re-resistored line/phono stage when I discovered the broken wafer.

It MAY becthe same as a PAT4. Does anyone have one or have a source for one. Ebay and Marketplace searches come up with nothing.

Thanks in advance,

Stuart

Is there any chance you can repair it? Two-part epoxy can be amazing in situations like that.

Author:  DaveR [ November 5th, 2020, 4:10 pm ]
Post subject:  Re: Dynaco SCA80Q Selector Switch

I doubt if what I have is an exact replacement, but I do have a few selector switches that are new. Can you provide some details, perhaps a picture or two. I'll do the same, probably today.

Author:  Stuart Polansky [ November 5th, 2020, 5:20 pm ]
Post subject:  Re: Dynaco SCA80Q Selector Switch

After looking at my progress pictures, I see that I broke the switch. As careful as I thought I was being, the bending moment from trying to neatly remove those 10k resistors obviously broke it.

Here are pictures of the damage and a section of the wiring diagram.

Thanks again.

Attachments:
Upper_Break.jpg
Upper_Break.jpg [ 918.75 KiB | Viewed 864 times ]
Selector_Wiring.PNG
Selector_Wiring.PNG [ 371.6 KiB | Viewed 864 times ]
Broken_Wafer_Switch.jpg
Broken_Wafer_Switch.jpg [ 1.29 MiB | Viewed 864 times ]

Author:  Stuart Polansky [ November 5th, 2020, 5:25 pm ]
Post subject:  Re: Dynaco SCA80Q Selector Switch

Another useless pic

Attachments:
Lower_Break.jpg
Lower_Break.jpg [ 961.57 KiB | Viewed 863 times ]

Author:  DaveR [ November 5th, 2020, 5:28 pm ]
Post subject:  Re: Dynaco SCA80Q Selector Switch

I took a look at what I have and they are both basic selector switches so I'm afraid I'm not going to be able to help you out. Good luck.

Author:  SoundMods [ November 5th, 2020, 6:33 pm ]
Post subject:  Re: Dynaco SCA80Q Selector Switch

Stuart Polansky wrote:
After looking at my progress pictures, I see that I broke the switch. As careful as I thought I was being, the bending moment from trying to neatly remove those 10k resistors obviously broke it.

Here are pictures of the damage and a section of the wiring diagram.

Thanks again.

Hey Stu! Since the break is out of the way of any electrical connections -- and at the end of the wafer right at the mechanical connections -- I think you have a shot at a successful repair. Also I recommend cleaning the silver oxide off of the electrical connections.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/